1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Odd issue with MacOS Catalina

Discussion in 'Questions and Support' started by Jeremy, Oct 10, 2019.

  1. Jeremy

    Jeremy New Member

    Running client on a machine that was just upgraded to Catalina. App works fine, but every time I stop the app (I do this in the evening when I leave the office and then start it again when I come in the next day) it will not start the next time. Starting the app gets to where it asks for credentials. After credentials are entered the app dies.

    The only workaround is to uninstall and reinstall the app, so I'm doing this daily. It works, but is not idea.
  2. Dmitry Korobkin

    Dmitry Korobkin New Member

    I have the same bug :(
  3. Jeremy

    Jeremy New Member

    Discovered that uninstall is not necessary while trying to make an automator app. Made automator app with the following:

    do shell script "sudo installer -pkg /tmp/Across_Installer.pkg -target /" with administrator privileges

    So at least I'm back to launching a single app.

    Note that that took a bit of work on catalina due to some buggy things with automator. If that package was in my downloads folder I could not make it work. Found that any of what I'll call the true root filesystems (tmp, etc, opt, ..) worked just fine. Anything else gave a permissions issue no matter what I did.
    WindsorSean likes this.
  4. Jeremy

    Jeremy New Member

    Sorry, just realized that the automator is still not working.

    However, I put sudo installer -pkg /tmp/Across_Installer.pkg -target / in a shell script (called across_reinstall.sh) and then put an alias (like alias across='/tmp/across_reinstall.sh') in my bash profile (have not changed shell as Catalina suggests). So I can just open terminal and type across.
    WindsorSean likes this.
  5. WindsorSean

    WindsorSean New Member

    Thanks Jeremy for the tip, this will be really helpful for me as well. I hope it gets fixed soon!
  6. Jeremy

    Jeremy New Member

    Wow. Apparently I've been living under a rock. Just discovered that if you change that .sh extension to .command you can double click it and it will run in terminal. So, no need for the alias.
  7. Seungjin Lee

    Seungjin Lee Member

    Hi, guys,
    Apology for lazy response, and appreciate your patience.
    Across for macOS (V2.08) released. It fixed this issue and the installer package has been notarized.
    If you have any other issues, please feel free to let us know.

Share This Page