1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Scroll wheel/middle mouse button does not seem to work

Discussion in 'General Discussion' started by Wallace Winfrey, Dec 26, 2017.

  1. Wallace Winfrey

    Wallace Winfrey New Member

    So I tried this with both v1.33 and the v2.00b2b, but my mouse scroll wheel/middle mouse button/tilt (Logitech MX Ergo Plus trackball), with Windows 10 as the Across Server, does not seem to register scroll/clicks/tilts on my Across Client, OS X 10.13.2.

    This is with the Mouse Hotkey disabled. Scroll wheel use is ubiquitous in my habits, and on the client, the middle mouse button is my primary method of pasting text.

    Any ideas?
     
  2. Seungjin Lee

    Seungjin Lee Member

    I am somewhat confused with definitions of wheel/middle button/tilt.

    Wheel: Vertical Wheel? Doesn't it work?
    Middle mouse button: General Middle Button? Doesn't it work?
    Tilt: Horizontal Wheel? Doesn't it work?

    Have you already checked the User Manual for the middle button use in a client device?
    ===
    Note: If you are using a mouse settings software (e.g., SetPoint for Logitech, IntelliPoint for Microsoft, etc), please make sure that the middle button of your mouse is configured as "Middle Button".

    [​IMG]
     
  3. matt

    matt New Member

    I am having the same issue. I am using the logitech MX Master mouse. I have configured the scroll wheel as "Middle Button", but it does nothing when on the client. Client it a android tablet.
     
  4. matt

    matt New Member

    I fixed this problem. Went into logitech options software and restored defaults for my mouse. Now scroll button works.
     
  5. Wallace Winfrey

    Wallace Winfrey New Member

    Yes, it's configured as middle mouse button:

    [​IMG]

    I also tried resetting to defaults. Still no middle mouse button functionality of any kind.
     
    Last edited: Dec 31, 2017
  6. Seungjin Lee

    Seungjin Lee Member

    Wallace, Sorry for this lazy reply.

    Is your PC a laptop or a desktop? If it is a laptop and you have another PC to test, operate the 3rd PC as an Across Server and see how it works with your mice.

    Sometimes trackpad (touchpad) driver on a laptop could prevent Across from working properly.
     
  7. Wallace Winfrey

    Wallace Winfrey New Member

    Across Server is running on PC laptop, a ThinkPad with a Synaptics touchpad. Across Client is running on Macbook Pro running High Sierra. Unfortunately I don't have a third PC to test with at this time.

    I tried disabling the touchpad on both my ThinkPad and my MBP but it didn't make a difference.

    A couple more details that may add to your understanding of the issue:
    • The way my desktop is setup is, from left to right, ThinkPad <-> 22" external display connected via HDMI to ThinkPad <-> MacBook Pro.

    • I usually run a Linux VM on the external display in full-screen mode.

    • If I click into a window on my Macbook Pro, and try to use the scrollwheel, the VM will receive the input, but only for the scrollwheel. No other input, and only if the VM (ArchLinux, running in VirtualBox) is full-screened. If it is windowed, it will not receive the input. This only occurs in VirtualBox, other full-screened apps will not receive the scrollwheel input.

    • The behavior does not change on the Across Client if VirtualBox is not running.
     
  8. Seungjin Lee

    Seungjin Lee Member

    Sorry, I can't follow you fully. You mean that the mouse middle button inputs to the full-screened VM instead of the client?

    You mean that the mouse middle button works well in the client if the VM is not running or is in windowed mode?
     
  9. Wallace Winfrey

    Wallace Winfrey New Member

    That is correct. Mouse left and right button and mouse movement continue to go to the client, but the middle mouse button inputs to the full-screened VM.

    No, what I mean is, this behavior, where the mouse middle button inputs to VirtualBox, only occurs when VirtualBox is running in full-screen mode. It does not occur when VirtualBox is running in a window. It never inputs to the client.
     
  10. Seungjin Lee

    Seungjin Lee Member

    Thanks for your answer. Just for test purpose, could you please remove the Synaptics software (in "Program and Features" from "Control Panel") and let me know how the mouse middle button works?
     
  11. Wallace Winfrey

    Wallace Winfrey New Member

    Apologies for the long delay in responding. I removed the Synaptics software and it did not make a difference.

    Also, I connected my work laptop running Windows 10 v1703 (OS Build 15063.540) as a client and the scroll wheel does not work there either.
     
  12. G.B.Inquisitor

    G.B.Inquisitor New Member

    Hello, found this looking for a similar problem:
    https://communities.vmware.com/thread/575757

    I've had the problem that the TrackBall MX Ergo didn't scroll in guest sessions (VMware/RDP) .
    This works when turning of "SMOOTH SCROLLING" in the Logitech software. Maybe this will help you with your MacOS/VirtualBox issue, it sound for me like the same problem...
     
  13. Seungjin Lee

    Seungjin Lee Member

    Hello, G.B.Inquisitor,

    Across operation is very simple - capture input data and then forward them to a client device. The only possibility of malfuction is other app (possibly, input device SW or another 3rd party SW) would capture input data in advance of Across, and therefore Across could never get the input data.

    Across rewriting becomes almost done. Your comments enormously give me inspiration for enhancement. I promise the next version of Across will capture every single input data including middle button and wheel. Appreciate your comments greatly. ;)
     

Share This Page