1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Linux to Win disconnection right after pairing

Discussion in 'Bug Reports' started by sarimarton, Mar 9, 2023.

  1. Seungjin Lee

    Seungjin Lee Member

    Hard to type cause from phone.

    Change across start mode to Manual mode and exit Across Center. Then run the command, and run Across Center again.
  2. sarimarton

    sarimarton Member

    • I’ve set Configuration -> Autostart -> Disabled
    • Exited Across Center
    • Applied the command in Terminal
    • I noticed that it didn't finish. It asks for my password, but the command doesn't return to the shell, it keeps running.
    • I leave it as that and launch Across Center.
    • Mac prompts "Across Center wants to make changes" with a password field, I enter my password.
    • Trying to apply the licence code, but it's Error 15 again.
  3. Seungjin Lee

    Seungjin Lee Member

    Get back to u 2 hours later
  4. Seungjin Lee

    Seungjin Lee Member

    Your attached image shows that the command (
    sudo /Applications/Across/Across\ Center.app/Contents/MacOS/acrossd -il
    ) runs well.

    It's strange... Please try again.

    EDIT: I deleted the attached image showing your product key.
  5. sarimarton

    sarimarton Member

    I'm typing as I'm retrying but I can only produce the same sequence:
    - making sure "Configuration" / "Autostart..." / "Disabled" is set
    - quit Across Center (at this point "acrossd -il" finishes running)
    - Execute "sudo /Applications/Across/Across\ Center.app/Contents/MacOS/acrossd -il", it keeps running
    - leave the terminal running, launch Across Center ("open /Applications/Across/Across\ Center.app" in another terminal)
    - macOS prompts "Across Center wants to make changes", I type my password, approve
    - go to Licence Manager, paste key -> Error Code 15
  6. Seungjin Lee

    Seungjin Lee Member

    I think the license security info would go contaminated. I have requested the license solution provider tech support. I'll get back to you once replied. Thanks.
  7. Seungjin Lee

    Seungjin Lee Member

    Got reply, but they said they don't support old versions. :(

    I think you would say "acrossd finishes running" instead of "acrossd -il", because you didn't run "acrossd -il" at this point. Right?

    Normally, "sudo /Applications/Across/Across\ Center.app/Contents/MacOS/acrossd -il" must be done right away.
  8. sarimarton

    sarimarton Member

    Something strange happened. It works now.

    No, I meant "acrossd -il". During the day I was testing like that all the time, as it is seen in my screenshot. I was copy-pasting the command line from the forum. It didn't return, and when I re-started the test sequence, at the point I quit the Across UI, I noticed that the command which was running in the terminal finished.

    That was a fix behavior.

    Now reading your last comment I ran it without "-il", just to see what happens. You can follow this on the screenshot. It didn't finish as well, the licence still errored, so I interrupted it with ^C. And then I ran it with "-il" added again, and now it returned to the shell immediately. I had a positive feeling about it, and indeed, after this, licence activation worked.

    Phew, this was interesting.

    I think my case can be closed now. I have saved all the 2.30 versions as well as the patched .app bundle and the instructions. I hope this will grant me a happy predictable across usage for a long time now. Thanks very much, Seungjin, for your persisting support!

    EDIT: Re-reading the terminal log, it suggests that "-il" did return in some of my earlier attempts, which makes me confused. It might be the case that it returned, but there definitely were times when it did not. It's also 100% sure that I haven't tried without "-il", until before the last attempt. It seems like running it without "-il" somehow moved it through a stale situation after which "-il" could do the job well.

    Attached Files:

    Last edited: Mar 14, 2023
    Seungjin Lee likes this.
  9. Seungjin Lee

    Seungjin Lee Member

    Glad to hear that! This is the description about the error:
    Shortly it says "please try this way, that way or another". You did it. :D

    For your reference, -il means "initialize license". Normally, acrossd runs with no parameters. "sudo acrossd -il" is executed once during installation. (it crashes for your case.)

    Full list using the old license management library
    macOS 10.9-10.11: https://download.acrosscenter.com/tmp/AcrossCenter-10.9.zip
    macOS 10.12: https://download.acrosscenter.com/tmp/AcrossCenter-10.12.zip
    macOS 10.13: https://download.acrosscenter.com/tmp/AcrossCenter-10.13.zip
    macOS 10.14-15: https://download.acrosscenter.com/tmp/AcrossCenter-10.14.zip
    Last edited: Mar 24, 2023
  10. sarimarton

    sarimarton Member

    Interesting tech insight, thanks again! I saved all these versions in my treasure vault :)
    Seungjin Lee likes this.

Share This Page