1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Test Flight for V2.BETA4-RC (RC3 uploaded)

Discussion in 'General Discussion' started by Seungjin Lee, May 4, 2019.

  1. Seungjin Lee

    Seungjin Lee Member

  2. Amadeus

    Amadeus New Member

  3. Amadeus

    Amadeus New Member

  4. Amadeus

    Amadeus New Member

    Weird, I eventually got it to work by clicking around and uninstalling/re-installing
  5. Wallace Winfrey

    Wallace Winfrey New Member

    This is working great so far - except when I drag my mouse to the right from my Windows 10 server desktop to the desktop of my OS X Mojave client, the mouse will not re-enter the server desktop if I move the mouse to the left-hand side of the screen; my expectation is for the mouse to re-appear on the left-hand side of the Windows 10 server desktop. I have to enter the keyboard combo to get it to switch back.

    Also, while the scroll wheel works, middle-mouse button functionality seems to be missing. When I run a device analyzer, it does not detect input from the middle mouse button. I have the switch desktop by middle mouse button config turned off.
  6. Seungjin Lee

    Seungjin Lee Member

    @Wallace Winfrey,
    Both of you guys problem is this: https://community.acrosscenter.com/...10-14-mojave-accessibility-configuration.170/
    3. Register acrossd in the exception list:
    1. Open "System Preferences" and go to "Security&Privacy" and "Privacy" tab. In the "Privacy Tab", choose "Accessibility" from the left-pane.
    2. Click on the lock icon on the bottom left corner and enter password.
    3. From Finder menu bar, click "Go" > "Go to Folder..." and then input /usr/local/sbin to the "Go to the folder:" path. Click acrossd and drag-drop it to the exception list.
    NOTE: Even if acrossd is listed in the exception list, macOS could not apply it as an exception. In this case, please try to remove acrossd from the exception list and then add it to the list again.

    You can disregard the message safely, but if you want to get the correct message, go to "System Preferences" > "Security & Privacy", choose "Automation" from the left pane and then check "System Events" under "Across Uninstaller" from the right pane.

    @Wallace Winfrey,
    I remember you are using the middle button as "Paste" and am guessing the middle button of your mouse may not be the "Middle Button" but the "Paste". Just test with other mouse. It must work. I mean Across does not redirect the "Paste" but the "Middle Button".
    Last edited: May 5, 2019
  7. Amadeus

    Amadeus New Member

  8. Seungjin Lee

    Seungjin Lee Member

    You're right. I released the RC too urgently, since I promised to a user that I would release the update within this week. To keep the promise, the first posting has the minimal. (Also I'm very tired.) It will be revised.

    If you mean that you want to know how to configure for a Mac client as an Across client, the same configuration is needed for both Across Server and Client.

    Thanks for the report. I have found something in macOS changed from macOS 10.14, and have changed the feature work correctly. You can download the revamped version from the original posting.
    Last edited: May 5, 2019
  9. Amadeus

    Amadeus New Member

    No worries, wasn't trying to rush you or anything, and given it's already on your radar, no worries. It's completely understandable it's unfinished at the moment.

    Also, thanks for the ctrl key fix! Works great!
  10. Jimmy_Jones

    Jimmy_Jones New Member


    I've updated my Windows Across client (for the server), and have updated my Android client however when I select the "Operation" button to enable, the app closes...therefore I cannot enable Operation on my Android device (Huawei P30)
  11. Wallace Winfrey

    Wallace Winfrey New Member

    This worked. Thanks.

    OK, so FWIW, this is not middle-mouse button paste. I'm using the utility "SteerMouse", which has a device analyzer function, and using this utility, I am unable to detect any activity from pressing the middle button.

    I did an OSX screen capture of the behavior I'm seeing with SteerMouse's Device Analyzer. The sequence of actions is:
    1. Launch Device Analyzer
    2. Click Left Mouse Button
    3. Click Right Mouse Button
    4. Move Scroll Wheel Up & Down
    5. Middle Mouse Button
    6. Click Left Mouse Button
    7. Click Right Mouse Button
    8. Move Scroll Wheel Up & Down
    9. Middle Mouse Button
    QuickTime's "Show mouse clicks in recording" option is also checked. You can see the black/white circle when I press the left mouse button, and the green circle when I press the right mouse button. In both the diagnostic feedback (the hex output in the Report column) and the OSX screen capture, the middle mouse button presses are not recorded.

    I suppose it could be an incompatibility with my Logitech ErgoMX. Also, I haven't tried 2BETA4RC2 yet, but will and will post feedback. Thanks for the prompt bugfixes!

    Attached Files:

  12. Seungjin Lee

    Seungjin Lee Member

    If you can purchase a support ticket (US $1,000) for the problem, we will fix it at the highest level. We don't have the phone. Alternatively, you can use a phone in which across works well.
    Last edited: May 6, 2019
  13. Seungjin Lee

    Seungjin Lee Member

    @Wallace Winfrey, Isn't your mouse connected to your Win PC? If it's connected to your Win PC, I can't understand if your observation have any meaning, since (I think) the middle button would not be generated even in your PC.
    I can't understand what you are saying. Please describe your problem in more details.
  14. Wallace Winfrey

    Wallace Winfrey New Member

    The middle mouse button works just fine on the Windows server. The Across software does not send middle-mouse button clicks (although it does send scroll wheel events after turning off smooth scrolling) to the OSX client.
  15. Seungjin Lee

    Seungjin Lee Member

    @Wallace Winfrey,
    Aha,, I think I can understand you intention. If you can purchase a support ticket (US $750, or US $1,500 depending on your mouse driver structure -- If it has the same structure as a Logitech device, it is $750. Otherwise (it has the same structure as a MS device), it is $1,500), I can guarantee that your mouse (the special model only) must work like your Logitech mouse. If you want to do that, just shoot a mail to us.
    Last edited: May 6, 2019
  16. Lee Rhoads

    Lee Rhoads New Member

    Seungjin Lee,

    I had to do the following for both the V2.BETA4-RC and the V2.BETA4-RC2 Windows installers:
    (1) uninstall currently installed version of Across (as you directed in your first post)
    (2) uninstall "Microsoft Visual C++ 2017 Redistributable (x64) - 14.16.27027"
    (3) install Across
    (4) uninstall "Microsoft Visual C++ 2017 Redistributable (x64) - 14.16.27012"
    (5) re-install "Microsoft Visual C++ 2017 Redistributable (x64) - 14.16.27027"

    Otherwise the Across installers would fail with the following error:

    Error: "An error occurred while installing system components for Across. Setup cannot continue until all system components have been successfully installed."

    Details: 'Component Visual C++ "14" Runtime Libraries (x64) has failed to install wth the following error message: "Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel." The following components failed to install: - Visual C++ "14" Runtime Libraries (x64). See the setup log file located at C:\Users\Lee\AppData\Local\Temp\VSD60C.tmp\install.log' for more information.'

  17. Lee Rhoads

    Lee Rhoads New Member

    Seungjin Lee,

    To clarify: On my PC both of the beta Across Windows installers (V2.BETA4-RC and V2.BETA4-RC2) insist on having the old version 14.16.27012 of "Microsoft Visual C++ 2017 Redistributable (x64)" installed and won't succeed until I first uninstall the newer version 14.16.27027. I need the newer version for other software. I have been putting the newer version back each time after successfully installing Across, including in between trying Across V2.BETA4-RC and Across V2.BETA4-RC2. Hence, my always running my step # (2) uninstall "Microsoft Visual C++ 2017 Redistributable (x64) - 14.16.27027".

  18. Christopher Kenly

    Christopher Kenly New Member

    Mr. Lee

    I just wanted to let you know that the Android client on my Galaxy S10+ crashes everytime that i go to load the 1.50 version to connect. I reinstalled the 1.43 version and it connects to the new client but locks the mouse and keyboard to the android device after about 1 minute.

    Please let me know what i can do to help.

  19. Seungjin Lee

    Seungjin Lee Member

    Hello, everyone,

    RC3 uploaded.

    @Jimmy_Jones, @Christopher Kenly, please try the android version in your phone. I think the problem would be fixed.

    @Lee Rhoads, please try the new version in your tablet pc.

    @Wallace Winfrey, please test the new version with your mouse, and let us know your mouse model info.

    Thanks in advance for all your helps.
    Last edited: May 15, 2019
  20. Jimmy_Jones

    Jimmy_Jones New Member

    Thank you, that is working now.

    The input lag for moving the mouse is still quite high but the mouse scroll button works fine.

Share This Page