1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mouse pointer stuck on client

Discussion in 'Bug Reports' started by natcef, Nov 1, 2015.

  1. natcef

    natcef New Member

    I'm having a problem with the mouse pointer getting stuck on a client device (Windows 8), and not returning to the server (OS X). This problem has occurred twice in a row now and seems to be caused by (full-screen) video being played from a browser on the client (Vivaldi/Chrome browser), messing up the Across client.

    The cursor remains stuck on the client device, and there is no way to return it to the server except to disable the Across operation on the client using the tray icon.

    This is a pretty severe issue, causing the user to lose mouse and keyboard control of the host. I would suggest e.g. adding a hot key that forces a return of the mouse and keyboard to the host at any time.

    Affected version: 1.0.2
    Server OS: Mac OS X Yosemite 10.10.5
    Client OS: Windows 8.1
     
  2. Universe

    Universe New Member

    Welcome to the across community and thanks for the report but I am having trouble reproducing the issue. Please give me some more details.

    1. Does 'the mouse pointer getting stuck on a client' mean that the mouse pointer doesn't move on the client or that the mouse pointer doesn't return to the server? Otherwise both?

    2. Across provides the keyboard and mouse hotkey to switch the keyboard/mouse input focus between devices besides mouse dragging between devices. Please see the section 6.1 for the hotkeys in the manual page: http://www.acrosscenter.com/manual/control
    Do you mean that the keyboard and mouse hotkey don't work in the situation?

    3. Does the full-screen video play mean the full-screen video play in youtube like site?

    Seung-Jin Lee
    Across Developer
     
  3. natcef

    natcef New Member

    Thanks for the quick reply. As far as your questions go:

    1. The issue here is that the mouse pointer remains on the client's screen at all time, with no way to return to the server. The screen boundaries no longer seem to function as a means of returning the pointer.

    2. I have not been able to get the hotkeys working at all on OS X. I guess this would be a separate issue, but I'm having trouble understanding how these work at all. The specified default key combinations do not seem to work. Furthermore, I do not have access to a middle mouse button as I am using a Macbook. In my particular case, a gesture would be ideal instead. Again though, I don't want to clutter up this bug report.

    3. The full-screen video refers to a YouTube (HTML5) video being played in a browser (in this case, Vivaldi) in full-screen mode.
     
  4. Universe

    Universe New Member

    Thanks again for the answer. I guess that there may not be the Bluetooth RFCOMM connection between devices.

    1) Have you installed the 'Across Client' on your client Windows computer? If not, you need to install the 'Across Client' on the client Windows computer.

    2) If you have installed the 'Across Client' on your client Windows computer but the shape of the system tray icon is not [​IMG], I think the Bluetooth stack on the client Windows computer may not be the Microsoft Windows Bluetooth stack. Please check Q1.2 on how to check the Microsoft Windows Bluetooth stack and Q1.3 on how to change the Bluetooth stack on your computer to the Microsoft Windows Bluetooth stack in the FAQ page.

    3) Regarding the keyboard hotkey, pressing the specified keys simultaneously will work. If the specified key for input switch is the option-key, press both left and right option keys at the same time to switch the input focus between devices. About the mouse hotkey, please test it by connecting a mouse having the middle button to your Macbook.

    Hope it helps.
     
  5. natcef

    natcef New Member

    1. Yes, hence I was able to return control to the server by disabling the "Across Operation".

    2. The tray icon is identical to the one you are showing. The Across client seems to be functioning correctly, and no additional Bluetooth stack drivers are installed; this is a brand new Windows install.

    3. Ah, my mistake. I thought the correct hotkey combination was Left + Option or Right + Option, but your explanation suggests that it is actually the left and right option keys. This makes a lot more sense and actually works! Perhaps it is an idea to mention this more explicitly somewhere?

    P.S. Another minor bug not worthy of a separate thread I found with the OS X 1.0.2 version is a spelling mistake on one of the tabs: "Multimeida-Key".

    Let me note that Across is working 100% fine most of the time, including the client/server switching. It is just that certain situations cause it to get "stuck".
     
  6. Universe

    Universe New Member

    Thanks a lot for the confirmation. :) I will look into the issues you mention thoroughly.
     
  7. Seungjin Lee

    Seungjin Lee Member

    I have been trying to reproduce the issue of the mouse pointer getting stuck on a client device, but still failed. I am suspecting that you may experience those situations from Windows 8(.1)'s Hotcorner. Both Across Server and Client on Windows 8(.1) don't change the input focus when the mouse pointer is on the Hotcorner area.

    I will keep looking into it and if you find the explicit situation, please let me know.
     
  8. Derek

    Derek New Member

    i have this issue! - win10 android 6 current across software as at today's date
     
  9. Max Cascone

    Max Cascone New Member

    I just started having this issue too. I've been using the paid version for a few weeks. The mouse (and keyboard) transfer perfectly over to the client, but won't transfer back.
    The keyboard hotkey works to get the mouse back to the server.
    I didn't change anything, it just started happening.

    I should add that the Connection Status only shows BT-HID active.

    Across v2.00.beta2.c
    Server: Win10
    Client: Mac OS 10.11.6
     

Share This Page