1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issue: Unstable bluetooth connection on MacOS Mojave 10.14.5

Discussion in 'Bug Reports' started by Matthew Thiel, Jul 6, 2019.

  1. Matthew Thiel

    Matthew Thiel New Member

    I'm running Across server 2.03 on a Windows 10 machine and using a Macbook Air as a client. Everything functions correctly, but the Mac continuously displays the "Connected" and "Connection Lost" messages in the middle of the screen every few minutes. I configured both to prefer IP networking, so it works fine even as it keeps losing bluetooth connections. Unfortunately, the frequent pop-up connect/disconnect messages are too distracting to actually use the Mac and there's a brief interruption in mouse movement every time it happens.

    I read the previous threads about similar problems in High Sierra, but this was supposed to be fixed by Apple back in the Mojave beta according to this thread: https://community.acrosscenter.com/...-10-13-high-sierra-bluetoothaudiod-issue.118/

    Is it possible this is the same bluetoothaudiod issue come back, or is that definitely still fixed in recent Mojave versions?
     
  2. Seungjin Lee

    Seungjin Lee Member

    Please try to disable/reenable Bluetooth in your Windows 10 PC. The symptom would always occur after pairing with a Mac. Disable/reenable Bluetooth fix it for me, and no more problem after that.

    I guess the cause of the issue may be the bluetoothaudiod. Their claim that they would fix the issue is just their claim. Definitely the issue has not been resolved yet.
     
  3. Matthew Thiel

    Matthew Thiel New Member

    Okay, that DOES seem to settle things down... It never really occurred to me to just disable/enable the BT device in Windows, as I've restarted several times which I assumed would accomplish the same thing.

    Thanks for the advice, I'll see how it goes!

    I didn't do much research to confirm, but I'll dig around and gather some info if it persists.
     
  4. Wallace Winfrey

    Wallace Winfrey New Member

    Hello, I am experiencing this issue with Catalina: Across server is Windows 10 Pro, Across client is OSX Catalina. I have tried disabling/enabling bluetooth on Windows 10 Pro host. Sometimes it works without issue for many hours. Other times connection and disconnection is constant, every 30 seconds. Currently it is disconnecting and reconnecting every 30-60 seconds, and is essentially unusable. I have disabled Handoff in OSX. Is this still a recommended solution?

    https://community.acrosscenter.com/...gh-sierra-bluetoothaudiod-issue.118/#post-637
     
    Last edited: May 25, 2020
  5. Seungjin Lee

    Seungjin Lee Member

  6. Wallace Winfrey

    Wallace Winfrey New Member

    So, with SIP disabled, I re-mounted the filesystem rw, edited the file, stopped & restarted bluetoothaudiod, disabled & re-enabled bluetooth on host machine and am still seeing disconnects every 15 seconds. Sometimes the outage is for 10 seconds, other times it is up to a minute.

    It is essentially broken in this state.
     
  7. Seungjin Lee

    Seungjin Lee Member

  8. Wallace Winfrey

    Wallace Winfrey New Member

    So far I've tried turning bluetooth off and back on, on the Windows host; I also reset my bluetooth module on the OSX client. I also edited /System/Library/LaunchDaemons/com.apple.bluetoothaudiod.plist on the OSX client.

    There is a definite pattern, time length-wise, in the disconnects. The sequences goes as follows:

    15 seconds connected
    5 seconds disconnected
    15 seconds connected
    5 seconds disconnected
    15 seconds connected
    30 seconds disconnected

    and then it repeats.

    If I don't attempt to use my computer for a while, I'm not sure how long, at least an hour, the cycle stops and it just stayed connected, until one of the machines restarts or goes to sleep. Setting a bluetooth or network preference doesn't seem to make a difference.
     
  9. A Chan

    A Chan New Member

    Any updates on this? I'm having the same issue with Catalina and Windows 10.
     
  10. A Chan

    A Chan New Member

    I figured this out. You need to turn off power save for the Clixon Virtual HID device. Go to Device Manager->Human Interface Devices -> Clixon Virtual HID. Click on Power management tab and unselect "Allow computer to turn off this device to save power". 15 second drops stop happening!
     

Share This Page