1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

acrossd 2.08a fails w/ 255 when called from launchd in Catalina 10.15.2

Discussion in 'Questions and Support' started by Scott Mann, Dec 13, 2019.

  1. Scott Mann

    Scott Mann New Member

    I can run sudo /usr/local/sbin/acrossd from the terminal and it works perfectly, but if it's instead launched from launchd, it runs for a second and then exits with a return code of 255.

    I tried reinstalling. I've tried granting acrossd various System Preferences>Security & Privacy permissions, like Full Disk Access, Input Monitoring, Developer Tools. I've tried adding PATH environmental variables to com.clixon.acrossd.plist, or even have reattach-to-user-namespace execute acrossd. I've tried having launchd execute /usr/sh -c /usr/local/sbin/acrossd.

    Unfortunately, I only first installed across center after having already upgraded to 10.15.2, so I have no idea if the issue is actually related to this new version of macOS, or not.

    Oh, just in case it's relevant, instead of using homebrew to install openssl@1.1, I actually already had it installed via macports, so I just created a symbolic link from /usr/local/opt/openssl@1.1 to /opt/local, which seems to work fine. (Homebrew and macports don't play well together.)

    I just want acrossd to launch automatically, without having to launch it manually from the terminal.

    Any advice would be appreciated!
    Last edited: Dec 13, 2019
  2. Seungjin Lee

    Seungjin Lee Member

    Hi, Scott Mann,

    Sorry about the problem. I think your problem would be related with the 10.15.2 update, specifically, the notarization requirement of macOS.
    We will look into it after 10.15.2 update ASAP. Thank you.
  3. Seungjin Lee

    Seungjin Lee Member

    Updated to 10.15.2 and have no problem in running acrossd by launchctl.

    Are there other users experiencing this issue?
  4. Seungjin Lee

    Seungjin Lee Member

    Aha,, I think you need to install a notarized version of openssl. Homebrew could provide a notarized version, but I guess Macport would not. So, I recommend to install openssl from Homebrew.
  5. Seungjin Lee

    Seungjin Lee Member


    I noticed this issue would occur in some situations including shutdown, restart or logout. It's an obvious bug of acrossd. Really sorry about this issue. We will release the next version in the coming month.
    In the mean time, please use the following measure:

    1. Download acrossd.zip using this link -- https://download.acrosscenter.com/tmp/acrossd.zip, and unzip it.
    2. Open a Terminal, and go to the unzipped directory.
    3. Run the following 2 commands:
    $sudo cp -f ./acrossd /usr/local/sbin
    $sudo killall -9 acrossd

    Tha's it. Thanks a lot for your report.

Share This Page